aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.0/720-phy_adm6996.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.0/720-phy_adm6996.patch')
-rw-r--r--target/linux/generic/patches-4.0/720-phy_adm6996.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.0/720-phy_adm6996.patch b/target/linux/generic/patches-4.0/720-phy_adm6996.patch
new file mode 100644
index 0000000..0f8b261
--- /dev/null
+++ b/target/linux/generic/patches-4.0/720-phy_adm6996.patch
@@ -0,0 +1,26 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -132,6 +132,13 @@ config MICREL_PHY
+ ---help---
+ Supports the KSZ9021, VSC8201, KS8001 PHYs.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ select SWCONFIG
++ ---help---
++ Currently supports the ADM6996FC and ADM6996M switches.
++ Support for FC is very limited.
++
+ config FIXED_PHY
+ tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_BCM7XXX_PHY) += bcm7xxx.o
+ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o