aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/smp
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/smp')
-rw-r--r--target/linux/brcm63xx/smp/config-default13
-rw-r--r--target/linux/brcm63xx/smp/target.mk8
2 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/smp/config-default b/target/linux/brcm63xx/smp/config-default
new file mode 100644
index 0000000..8afdf5e
--- /dev/null
+++ b/target/linux/brcm63xx/smp/config-default
@@ -0,0 +1,13 @@
+CONFIG_CPU_RMAP=y
+# CONFIG_KEXEC is not set
+CONFIG_MUTEX_SPIN_ON_OWNER=y
+CONFIG_NR_CPUS=2
+CONFIG_RCU_STALL_COMMON=y
+CONFIG_RFS_ACCEL=y
+CONFIG_RPS=y
+CONFIG_SMP=y
+CONFIG_SMP_UP=y
+CONFIG_STOP_MACHINE=y
+CONFIG_TREE_RCU=y
+CONFIG_USE_GENERIC_SMP_HELPERS=y
+CONFIG_XPS=y
diff --git a/target/linux/brcm63xx/smp/target.mk b/target/linux/brcm63xx/smp/target.mk
new file mode 100644
index 0000000..b0ccf97
--- /dev/null
+++ b/target/linux/brcm63xx/smp/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=smp
+
+define Target/Description
+ Build firmware images for BCM63XX boards with SMP support.
+ Currently only BCM6362 and BCM6368 supported.
+endef
+
+