aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/au1000/au1500/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/au1000/au1500/profiles')
-rw-r--r--target/linux/au1000/au1500/profiles/Atheros.mk13
-rw-r--r--target/linux/au1000/au1500/profiles/InternetBox.mk18
-rw-r--r--target/linux/au1000/au1500/profiles/MeshCube.mk18
3 files changed, 49 insertions, 0 deletions
diff --git a/target/linux/au1000/au1500/profiles/Atheros.mk b/target/linux/au1000/au1500/profiles/Atheros.mk
new file mode 100644
index 0000000..75e8e10
--- /dev/null
+++ b/target/linux/au1000/au1500/profiles/Atheros.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-ath5k
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/au1000/au1500/profiles/InternetBox.mk b/target/linux/au1000/au1500/profiles/InternetBox.mk
new file mode 100644
index 0000000..a73f0ce
--- /dev/null
+++ b/target/linux/au1000/au1500/profiles/InternetBox.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/InternetBox
+ NAME:=T-Mobile "InternetBox"
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-ohci kmod-usb-serial kmod-usb-serial-option \
+ comgt
+endef
+
+define Profile/InternetBox/Description
+ Package set for the T-Mobile "InternetBox" (TMD SB1-S)
+endef
+
+$(eval $(call Profile,InternetBox))
diff --git a/target/linux/au1000/au1500/profiles/MeshCube.mk b/target/linux/au1000/au1500/profiles/MeshCube.mk
new file mode 100644
index 0000000..5f0c14f
--- /dev/null
+++ b/target/linux/au1000/au1500/profiles/MeshCube.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MeshCube
+ NAME:=MeshCube MTX-1
+ PACKAGES:=kmod-ath5k kmod-hostap kmod-hostap-pci kmod-net-prism54 \
+ kmod-usb-core kmod-usb-ohci kmod-usb-storage kmod-fs-ext4 kmod-fs-vfat
+endef
+
+define Profile/MeshCube/Description
+ Package set for the 4G MeshCube (MTX-1)
+endef
+
+$(eval $(call Profile,MeshCube))