aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath25/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath25/Makefile')
-rw-r--r--target/linux/ath25/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ath25/Makefile b/target/linux/ath25/Makefile
new file mode 100644
index 0000000..ae867e9
--- /dev/null
+++ b/target/linux/ath25/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ath25
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs low_mem
+MAINTAINER:=Sergey Ryazanov <ryazanov.s.a@gmail.com>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+
+define Target/Description
+ Build firmware images for Atheros SoC boards
+endef
+
+$(eval $(call BuildTarget))