aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/mikrotik/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/mikrotik/profiles')
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/01-minimal.mk16
-rw-r--r--target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk16
2 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
new file mode 100644
index 0000000..3651c88
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DefaultNoWifi
+ NAME:=Default Profile (no WiFi)
+ PACKAGES:=
+endef
+
+define Profile/DefaultNoWifi/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
new file mode 100644
index 0000000..a291ff6
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ath5k
+ NAME:=Atheros WiFi (ath5k)
+ PACKAGES:=kmod-ath5k -kmod-ath9k
+endef
+
+define Profile/Ath5k/Description
+ Package set compatible with hardware using Atheros WiFi cards.
+endef
+$(eval $(call Profile,Ath5k))