aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
new file mode 100644
index 0000000..24d7d5c
--- /dev/null
+++ b/target/linux/ar71xx/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2008-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ar71xx
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=mips16
+CPU_TYPE=34kc
+SUBTARGETS:=generic nand mikrotik
+
+KERNEL_PATCHVER:=4.1
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ kmod-gpio-button-hotplug swconfig \
+ kmod-ath9k wpad-mini uboot-envtools
+
+$(eval $(call BuildTarget))