aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/Makefile')
-rw-r--r--target/linux/adm5120/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
new file mode 100644
index 0000000..419c534
--- /dev/null
+++ b/target/linux/adm5120/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2007-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+BOARD:=adm5120
+BOARDNAME:=Infineon/ADMtek ADM5120
+FEATURES:=low_mem
+SUBTARGETS:=router_le router_be rb1xx
+INITRAMFS_EXTRA_FILES:=
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+ kmod-input-polldev kmod-input-gpio-keys-polled kmod-button-hotplug \
+ kmod-leds-gpio kmod-ledtrig-adm5120-switch
+
+$(eval $(call BuildTarget))