aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iftop
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/iftop')
-rw-r--r--package/network/utils/iftop/Makefile43
-rw-r--r--package/network/utils/iftop/patches/0001-force-ncurses.patch12
2 files changed, 55 insertions, 0 deletions
diff --git a/package/network/utils/iftop/Makefile b/package/network/utils/iftop/Makefile
new file mode 100644
index 0000000..037fb15
--- /dev/null
+++ b/package/network/utils/iftop/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iftop
+PKG_VERSION:=1.0pre2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
+PKG_MD5SUM:=fef521a49ec0122458d02c64212af3c5
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/iftop
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libpcap +libncurses +libpthread
+ TITLE:=display bandwith usage on an interface
+ URL:=http://www.ex-parrot.com/~pdw/iftop/
+endef
+
+define Package/iftop/description
+ iftop does for network usage what top(1) does for CPU usage. It
+ listens to network traffic on a named interface and displays a
+ table of current bandwidth usage by pairs of hosts. Handy for
+ answering the question 'why is our ADSL link so slow?'.
+endef
+
+define Package/iftop/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/iftop $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,iftop))
diff --git a/package/network/utils/iftop/patches/0001-force-ncurses.patch b/package/network/utils/iftop/patches/0001-force-ncurses.patch
new file mode 100644
index 0000000..bf23fb4
--- /dev/null
+++ b/package/network/utils/iftop/patches/0001-force-ncurses.patch
@@ -0,0 +1,12 @@
+diff -ru iftop-1.0pre2-old/configure iftop-1.0pre2/configure
+--- iftop-1.0pre2-old/configure 2011-10-04 13:30:30.000000000 -0700
++++ iftop-1.0pre2/configure 2012-09-09 22:26:05.000000000 -0700
+@@ -7568,7 +7568,7 @@
+ { $as_echo "$as_me:$LINENO: checking for a curses library containing mvchgat" >&5
+ $as_echo_n "checking for a curses library containing mvchgat... " >&6; }
+ oldLIBS=$LIBS
+-for curseslib in ncursesw curses ncurses ; do
++for curseslib in ncurses ; do
+ LIBS="$oldLIBS -l$curseslib"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */