aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/swconfig/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/swconfig/src/Makefile')
-rw-r--r--package/network/config/swconfig/src/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/network/config/swconfig/src/Makefile b/package/network/config/swconfig/src/Makefile
new file mode 100644
index 0000000..1176bf0
--- /dev/null
+++ b/package/network/config/swconfig/src/Makefile
@@ -0,0 +1,15 @@
+ifndef CFLAGS
+CFLAGS = -O2 -g -I ../src
+endif
+LIBS=-lnl -lnl-genl
+
+all: swconfig
+
+%.o: %.c
+ $(CC) $(CFLAGS) -fPIC -c -o $@ $^
+
+libsw.so: swlib.o
+ $(CC) $(CFLAGS) -fPIC -shared -o $@ swlib.o
+
+swconfig: libsw.so cli.o uci.o
+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) -L./ -lsw