aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/cyassl/patches')
-rw-r--r--package/libs/cyassl/patches/100-respect_cflags.patch11
-rw-r--r--package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch10
-rw-r--r--package/libs/cyassl/patches/400-additional_compatibility.patch16
3 files changed, 37 insertions, 0 deletions
diff --git a/package/libs/cyassl/patches/100-respect_cflags.patch b/package/libs/cyassl/patches/100-respect_cflags.patch
new file mode 100644
index 0000000..94117ae
--- /dev/null
+++ b/package/libs/cyassl/patches/100-respect_cflags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,7 +47,7 @@ AC_SUBST([WOLFSSL_LIBRARY_VERSION])
+
+ # capture user C_EXTRA_FLAGS from ./configure line, CFLAGS may hold -g -O2 even
+ # if user doesn't override, no way to tell
+-USER_C_EXTRA_FLAGS="$C_EXTRA_FLAGS"
++USER_C_EXTRA_FLAGS="$CFLAGS"
+
+ LT_PREREQ([2.2])
+ LT_INIT([disable-static],[win32-dll])
diff --git a/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
new file mode 100644
index 0000000..00a23fe
--- /dev/null
+++ b/package/libs/cyassl/patches/300-SSL_set_tlsext_host_name.patch
@@ -0,0 +1,10 @@
+--- a/wolfssl/openssl/ssl.h
++++ b/wolfssl/openssl/ssl.h
+@@ -397,6 +397,7 @@ typedef WOLFSSL_X509_STORE_CTX X509_STOR
+ /* yassl had set the default to be 500 */
+ #define SSL_get_default_timeout(ctx) 500
+
++#define SSL_set_tlsext_host_name(x, y) wolfSSL_UseSNI(x, WOLFSSL_SNI_HOST_NAME, y, strlen(y))
+
+ #ifdef __cplusplus
+ } /* extern "C" */
diff --git a/package/libs/cyassl/patches/400-additional_compatibility.patch b/package/libs/cyassl/patches/400-additional_compatibility.patch
new file mode 100644
index 0000000..07956f1
--- /dev/null
+++ b/package/libs/cyassl/patches/400-additional_compatibility.patch
@@ -0,0 +1,16 @@
+--- a/cyassl/openssl/ssl.h
++++ b/cyassl/openssl/ssl.h
+@@ -24,4 +24,13 @@
+ *
+ */
+
++#ifndef CYASSL_OPENSSL_H_
++#define CYASSL_OPENSSL_H_
++
++#include <cyassl/ssl.h>
++#ifndef HAVE_SNI
++#undef CYASSL_SNI_HOST_NAME
++#endif
+ #include <wolfssl/openssl/ssl.h>
++
++#endif