aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/trace-cmd
diff options
context:
space:
mode:
Diffstat (limited to 'package/devel/trace-cmd')
-rw-r--r--package/devel/trace-cmd/Makefile63
-rw-r--r--package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch24
2 files changed, 87 insertions, 0 deletions
diff --git a/package/devel/trace-cmd/Makefile b/package/devel/trace-cmd/Makefile
new file mode 100644
index 0000000..6ed6673
--- /dev/null
+++ b/package/devel/trace-cmd/Makefile
@@ -0,0 +1,63 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=trace-cmd
+PKG_VERSION:=v2.4.2
+PKG_RELEASE=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=01f8e669cb035aa911f1ee0e3f94d535cbcca78f
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+# PKG_MIRROR_MD5SUM:=6a08dfa2519a969d184e7bb5bb390620
+PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
+PKG_LICENSE:=GPL-2.0
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/trace-cmd
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=Linux trace command line utility
+ DEPENDS:=
+endef
+
+define Package/trace-cmd-extra
+ SECTION:=devel
+ CATEGORY:=Development
+ TITLE:=Extra plugins for trace-cmd
+ DEPENDS:=
+endef
+
+MAKE_FLAGS += \
+ NO_PYTHON=1 \
+ prefix=/usr
+
+PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins
+PLUGINS_MAIN := function hrtimer mac80211 sched_switch
+
+TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
+
+define Package/trace-cmd/install
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/trace-cmd/plugins
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/trace-cmd $(1)/usr/bin/
+ $(CP) \
+ $(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_MAIN)) \
+ $(1)/usr/lib/trace-cmd/plugins
+endef
+
+define Package/trace-cmd-extra/install
+ $(INSTALL_DIR) $(1)/usr/lib/trace-cmd/plugins
+ $(CP) \
+ $$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
+ $$(filter-out $(PLUGINS_MAIN), \
+ $$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
+ $$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
+ $(1)/usr/lib/trace-cmd/plugins
+endef
+
+$(eval $(call BuildPackage,trace-cmd))
+$(eval $(call BuildPackage,trace-cmd-extra))
diff --git a/package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch b/package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch
new file mode 100644
index 0000000..e2a6897
--- /dev/null
+++ b/package/devel/trace-cmd/patches/110-mac80211_tracepoint.patch
@@ -0,0 +1,24 @@
+--- a/plugin_mac80211.c
++++ b/plugin_mac80211.c
+@@ -179,12 +179,15 @@ static int drv_config(struct trace_seq *
+ { 2, "IDLE" },
+ { 3, "QOS"},
+ );
+- pevent_print_num_field(s, " chan:%d/", event, "center_freq", record, 1);
+- print_enum(s, event, "channel_type", data,
+- { 0, "noht" },
+- { 1, "ht20" },
+- { 2, "ht40-" },
+- { 3, "ht40+" });
++ pevent_print_num_field(s, " chan:%d@", event, "control_freq", record, 1);
++ print_enum(s, event, "chan_width", data,
++ { 0, "20_noht" },
++ { 1, "20" },
++ { 2, "40" },
++ { 3, "80" },
++ { 4, "80p80" },
++ { 5, "160" });
++
+ trace_seq_putc(s, ' ');
+ SF("power_level");
+