aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/modules.mk
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /target/linux/lantiq/modules.mk
downloadtrunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.tar.gz
trunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.tar.bz2
trunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.zip
trunk-47381HEADmaster
Diffstat (limited to 'target/linux/lantiq/modules.mk')
-rw-r--r--target/linux/lantiq/modules.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
new file mode 100644
index 0000000..e7fbad3
--- /dev/null
+++ b/target/linux/lantiq/modules.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+I2C_LANTIQ_MODULES:= \
+ CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
+
+define KernelPackage/i2c-lantiq
+ TITLE:=Lantiq I2C controller
+ $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+ DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
+endef
+
+define KernelPackage/i2c-lantiq/description
+ Kernel support for the Lantiq/Falcon I2C controller
+endef
+
+$(eval $(call KernelPackage,i2c-lantiq))
+