aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
downloadtrunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.tar.gz
trunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.tar.bz2
trunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.zip
trunk-47381HEADmaster
Diffstat (limited to 'target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk')
-rw-r--r--target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk b/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
new file mode 100644
index 0000000..ca5295f
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-ath5k
+ NAME:=Broadcom SoC, all Ethernet, Atheros WiFi (ath5k)
+ PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-ath5k
+endef
+
+define Profile/Broadcom-ath5k/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+ b44, tg3 or bgmac Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-ath5k))
+