aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
new file mode 100644
index 0000000..afc0e65
--- /dev/null
+++ b/include/kernel-version.mk
@@ -0,0 +1,25 @@
+# Use the default kernel version if the Makefile doesn't override it
+
+LINUX_RELEASE?=1
+
+LINUX_VERSION-3.18 = .21
+LINUX_VERSION-4.0 = .9
+LINUX_VERSION-4.1 = .6
+
+LINUX_KERNEL_MD5SUM-3.18.21 = e4248caaa4cef318c04657e971b37298
+LINUX_KERNEL_MD5SUM-4.0.9 = 40fc5f6e2d718e539b45e6601c71985b
+LINUX_KERNEL_MD5SUM-4.1.6 = 1dae0c808e34164cab3dfd57be88bd53
+
+ifdef KERNEL_PATCHVER
+ LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
+endif
+
+split_version=$(subst ., ,$(1))
+merge_version=$(subst $(space),.,$(1))
+KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
+KERNEL_PATCHVER ?= $(KERNEL)
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM:=$(LINUX_KERNEL_MD5SUM-$(strip $(LINUX_VERSION)))
+LINUX_KERNEL_MD5SUM?=x