aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config/patches
diff options
context:
space:
mode:
authorJames <>2015-09-26 12:29:31 +0100
committerJames <>2015-09-26 12:29:31 +0100
commit626d9efa74685720020e816f3a917b7591d3cf7a (patch)
treed22eef73ae82287b30a1140decb4fc806d39d621 /tools/pkg-config/patches
downloadtrunk-47048-626d9efa74685720020e816f3a917b7591d3cf7a.tar.gz
trunk-47048-626d9efa74685720020e816f3a917b7591d3cf7a.tar.bz2
trunk-47048-626d9efa74685720020e816f3a917b7591d3cf7a.zip
trunk-47048
Diffstat (limited to 'tools/pkg-config/patches')
-rw-r--r--tools/pkg-config/patches/001-fix-package-rebuild.patch22
-rw-r--r--tools/pkg-config/patches/002-musl_host_fixup.patch24
2 files changed, 46 insertions, 0 deletions
diff --git a/tools/pkg-config/patches/001-fix-package-rebuild.patch b/tools/pkg-config/patches/001-fix-package-rebuild.patch
new file mode 100644
index 0000000..54f549c
--- /dev/null
+++ b/tools/pkg-config/patches/001-fix-package-rebuild.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -39,7 +39,7 @@
+ if HOST_TOOL
+ host_tool = $(host)-pkg-config$(EXEEXT)
+ install-exec-hook:
+- cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ uninstall-hook:
+ cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+ endif
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1093,7 +1093,7 @@
+ uninstall-man1
+
+ @HOST_TOOL_TRUE@install-exec-hook:
+-@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++@HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ @HOST_TOOL_TRUE@uninstall-hook:
+ @HOST_TOOL_TRUE@ cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+
diff --git a/tools/pkg-config/patches/002-musl_host_fixup.patch b/tools/pkg-config/patches/002-musl_host_fixup.patch
new file mode 100644
index 0000000..d39a738
--- /dev/null
+++ b/tools/pkg-config/patches/002-musl_host_fixup.patch
@@ -0,0 +1,24 @@
+--- a/glib/config.sub
++++ b/glib/config.sub
+@@ -122,9 +122,9 @@ esac
+ # Here we must recognize all the valid KERNEL-OS combinations.
+ maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
+ case $maybe_os in
+- nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
+- linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
+- knetbsd*-gnu* | netbsd*-gnu* | \
++ nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-musl* | \
++ linux-newlib* | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | \
++ kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
+ kopensolaris*-gnu* | \
+ storm-chaos* | os2-emx* | rtmk-nova*)
+ os=-$maybe_os
+@@ -1354,7 +1354,7 @@ case $os in
+ | -chorusos* | -chorusrdb* | -cegcc* \
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
+ | -mingw32* | -linux-gnu* | -linux-android* \
+- | -linux-newlib* | -linux-uclibc* \
++ | -linux-musl* | -linux-newlib* | -linux-uclibc* \
+ | -uxpv* | -beos* | -mpeix* | -udk* \
+ | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
+ | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \