summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorfishsoupisgood <github@madingley.org>2020-07-10 11:08:51 +0100
committerfishsoupisgood <github@madingley.org>2020-07-10 11:08:51 +0100
commit623a7e73cf79ecdda28fe5d3ff429090dbae359d (patch)
treebd35f492e210fe788500b98e41a8f4e733c2f563 /Makefile
parent93dbd25f15d4fb7e8b43411471c1e50f7ea77f6b (diff)
downloadpingid-623a7e73cf79ecdda28fe5d3ff429090dbae359d.tar.gz
pingid-623a7e73cf79ecdda28fe5d3ff429090dbae359d.tar.bz2
pingid-623a7e73cf79ecdda28fe5d3ff429090dbae359d.zip
make GPIO a parameterHEADmaster
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7fe50e9..0da8d7d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,8 @@
+
+ifneq (${GPIO},)
+ CFLAGS+=-DGPIO=${GPIO}
+endif
+
pingid:pingid.o
${CC} ${CFLAGS} ${LDFLAGS} -o $@ $< ${LIBS}