summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfishsoupisgood <github@madingley.org>2020-06-16 20:55:46 +0100
committerfishsoupisgood <github@madingley.org>2020-06-16 20:55:46 +0100
commit766d64916d507cac77e9b6b69cc14c59c9d75ecc (patch)
treed72eb2ffa4da94a89c98d3aeedc79c1dc024a24b
parent43e7d8d003f31bf9648e6bb82988fd33e93cda0f (diff)
downloadpingid-766d64916d507cac77e9b6b69cc14c59c9d75ecc.tar.gz
pingid-766d64916d507cac77e9b6b69cc14c59c9d75ecc.tar.bz2
pingid-766d64916d507cac77e9b6b69cc14c59c9d75ecc.zip
fish
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ed13995..7fe50e9 100644
--- a/Makefile
+++ b/Makefile
@@ -1 +1,9 @@
-pingid:pingid.c
+pingid:pingid.o
+ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ $< ${LIBS}
+
+clean:
+ /bin/rm -f pingid.o *~ pingid *.orig
+
+install:
+ mkdir -p ${DESTDIR}/usr/bin/
+ install -m 755 pingid ${DESTDIR}/usr/bin/