summaryrefslogtreecommitdiffstats
path: root/master/yubico-piv-tool
diff options
context:
space:
mode:
authorfishsoupisgood <github@madingley.org>2021-02-17 09:18:09 +0000
committerfishsoupisgood <github@madingley.org>2021-02-17 09:18:09 +0000
commitc495867b36e75b0cc8f1f423abcb973cac95cc1c (patch)
tree3abeecd4a77948eeadaf7388e79d122932755fcf /master/yubico-piv-tool
parent636d347e3df00f685923a30a4e11a95a49bd7b4c (diff)
downloadmaster-d20f4fc-pq-c495867b36e75b0cc8f1f423abcb973cac95cc1c.tar.gz
master-d20f4fc-pq-c495867b36e75b0cc8f1f423abcb973cac95cc1c.tar.bz2
master-d20f4fc-pq-c495867b36e75b0cc8f1f423abcb973cac95cc1c.zip
ship
Diffstat (limited to 'master/yubico-piv-tool')
-rw-r--r--master/yubico-piv-tool91
1 files changed, 91 insertions, 0 deletions
diff --git a/master/yubico-piv-tool b/master/yubico-piv-tool
new file mode 100644
index 0000000..8e27a0f
--- /dev/null
+++ b/master/yubico-piv-tool
@@ -0,0 +1,91 @@
+diff --git a/package/utils/yubico-piv-tool/Makefile b/package/utils/yubico-piv-tool/Makefile
+new file mode 100644
+index 0000000..d253fa5
+--- /dev/null
++++ b/package/utils/yubico-piv-tool/Makefile
+@@ -0,0 +1,85 @@
++#
++# Copyright (C) 2006-2014 OpenWrt.org
++# Copyright 2010 Vertical Communications
++# This is free software, licensed under the GNU General Public License v2.
++# See /LICENSE for more information.
++#
++
++include $(TOPDIR)/rules.mk
++
++PKG_NAME:=yubico-piv-tool
++PKG_VERSION:=1.7.0
++PKG_HASH:=624d818f675941efb411f14b198007cfefc0bc10d7104548c7e106c81236e3a9
++PKG_RELEASE:=1
++
++PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
++PKG_SOURCE_URL:=git://github.com/Yubico/yubico-piv-tool
++PKG_SOURCE_PROTO:=git
++PKG_SOURCE_VERSION:=yubico-piv-tool-1.7.0
++PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
++PKG_LICENSE:=BSD
++
++PKG_INSTALL:=1
++
++PKG_BUILD_PARALLEL:=1
++
++PKG_FIXUP:=autoreconf
++
++include $(INCLUDE_DIR)/package.mk
++
++define Package/yubico-piv-tool
++ SECTION:=utils
++ CATEGORY:=Utilities
++ TITLE:=yubico-piv-tool
++ DEPENDS:= +libpcsclite +check +libopenssl
++endef
++
++define Package/yubico-piv-tool/description
++ yubico-piv-tool
++endef
++
++
++
++#TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
++# $(INSTALL_DIR) $(1)/usr/bin
++# $(INSTALL_DIR) $(1)/usr/lib
++# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sympathy $(1)/usr/bin/
++# $(INSTALL_BIN) ${PKG_INSTALL_DIR}/usr/lib/libsympathy*.so* $(1)/usr/lib/
++
++# $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
++# $(INSTALL_BIN) ./files/sympathy.init $(1)/etc/init.d/sympathy
++
++
++#TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
++#TARGET_LDFLAGS += -flto
++
++#CONFIGURE_ARGS += \
++# --disable-testio-debug \
++# --enable-elf-shlibs \
++# --disable-libuuid \
++# --disable-libblkid \
++# --disable-uuidd \
++# --disable-tls \
++# --disable-nls \
++# --disable-rpath \
++# --disable-fuse2fs
++
++define Build/Compile
++ $(call Build/Compile/Default)
++ make -C $(PKG_BUILD_DIR) \
++ DESTDIR="$(PKG_INSTALL_DIR)" \
++ install
++endef
++
++
++define Package/yubico-piv-tool/install
++ $(INSTALL_DIR) $(1)/usr/bin
++ $(INSTALL_DIR) $(1)/usr/lib
++
++ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/yubico-piv-tool $(1)/usr/bin/
++ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libykcs11*.so* $(1)/usr/lib/
++ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libykpiv*.so* $(1)/usr/lib/
++endef
++
++
++$(eval $(call BuildPackage,yubico-piv-tool))