summaryrefslogtreecommitdiffstats
path: root/master/galaxy-tools
diff options
context:
space:
mode:
authorfishsoupisgood <github@madingley.org>2021-02-17 09:18:09 +0000
committerfishsoupisgood <github@madingley.org>2021-02-17 09:18:09 +0000
commitc495867b36e75b0cc8f1f423abcb973cac95cc1c (patch)
tree3abeecd4a77948eeadaf7388e79d122932755fcf /master/galaxy-tools
parent636d347e3df00f685923a30a4e11a95a49bd7b4c (diff)
downloadmaster-d20f4fc-pq-c495867b36e75b0cc8f1f423abcb973cac95cc1c.tar.gz
master-d20f4fc-pq-c495867b36e75b0cc8f1f423abcb973cac95cc1c.tar.bz2
master-d20f4fc-pq-c495867b36e75b0cc8f1f423abcb973cac95cc1c.zip
ship
Diffstat (limited to 'master/galaxy-tools')
-rw-r--r--master/galaxy-tools56
1 files changed, 56 insertions, 0 deletions
diff --git a/master/galaxy-tools b/master/galaxy-tools
new file mode 100644
index 0000000..c5cd3cd
--- /dev/null
+++ b/master/galaxy-tools
@@ -0,0 +1,56 @@
+diff --git a/package/jmm/galaxy_tools/Makefile b/package/jmm/galaxy_tools/Makefile
+new file mode 100644
+index 0000000..6405116
+--- /dev/null
++++ b/package/jmm/galaxy_tools/Makefile
+@@ -0,0 +1,50 @@
++#
++# Copyright (C) 2009 OpenWrt.org
++#
++# This is free software, licensed under the GNU General Public License v2.
++# See /LICENSE for more information.
++#
++
++include $(TOPDIR)/rules.mk
++
++PKG_NAME:=galaxy-tools
++PKG_VERSION:=2020-10-31
++PKG_RELEASE=$(PKG_SOURCE_VERSION)
++
++PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
++PKG_SOURCE_URL:=git://git.panaceas.org/galaxy/galaxy_tools
++PKG_SOURCE_PROTO:=git
++PKG_SOURCE_VERSION:=master
++PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.bz2
++
++
++PKG_NAME:=galaxy-tools
++PKG_RELEASE:=1
++
++include $(INCLUDE_DIR)/package.mk
++
++define Package/galaxy-tools
++ SECTION:=utils
++ CATEGORY:=Utilities
++ TITLE:=galaxy alarm tools
++ DEPENDS:= +libncursesw
++ VERSION:=1
++ MAINTAINER:=me <me@here>
++endef
++
++define Package/galaxy-tools/description
++ Tools for controlling galaxy dimension alarm panels
++endef
++
++define Build/Compile
++ make -C ${PKG_BUILD_DIR} CC=$(TARGET_CC)
++endef
++
++define Package/galaxy-tools/install
++ make -C $(PKG_BUILD_DIR) CC=${TARGET_CC} \
++ DESTDIR="$(1)" \
++ PREFIX=/usr \
++ install
++endef
++
++$(eval $(call BuildPackage,galaxy-tools))