summaryrefslogtreecommitdiffstats
path: root/master/ubi-root
diff options
context:
space:
mode:
authorJames <>2020-08-16 09:21:31 +0100
committerJames <>2020-08-16 09:21:31 +0100
commitf03c695ee4439c37fed1aabd5e76d233aee29be0 (patch)
treead62465aa676968490d9562938aec23444ba053f /master/ubi-root
downloadmaster-fa83455-pq-f03c695ee4439c37fed1aabd5e76d233aee29be0.tar.gz
master-fa83455-pq-f03c695ee4439c37fed1aabd5e76d233aee29be0.tar.bz2
master-fa83455-pq-f03c695ee4439c37fed1aabd5e76d233aee29be0.zip
happy
Diffstat (limited to 'master/ubi-root')
-rw-r--r--master/ubi-root24
1 files changed, 24 insertions, 0 deletions
diff --git a/master/ubi-root b/master/ubi-root
new file mode 100644
index 0000000..7f54317
--- /dev/null
+++ b/master/ubi-root
@@ -0,0 +1,24 @@
+diff --git a/include/image.mk b/include/image.mk
+index 9b3b3f2..a5f697c 100644
+--- a/include/image.mk
++++ b/include/image.mk
+@@ -279,6 +279,7 @@ endif
+ define Image/mkfs/ubifs
+ $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
+ $(UBIFS_OPTS) $(call param_unmangle,$(call param_get,fs,$(1))) \
++ -m 2048 -e 126976 -c 1024 \
+ $(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
+ $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--compr=none) \
+ $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--compr=lzo) \
+diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
+index c565c9b..a40884f 100644
+--- a/target/linux/ath79/nand/target.mk
++++ b/target/linux/ath79/nand/target.mk
+@@ -1,6 +1,6 @@
+ BOARDNAME := Generic devices with NAND flash
+
+-FEATURES += squashfs nand
++FEATURES += squashfs nand ubifs
+
+ DEFAULT_PACKAGES += wpad-basic
+