aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 272c625435..276233ef57 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -16,7 +16,7 @@ endif
tools-y += m4 autoconf automake bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2
-tools-y += wrt350nv2-builder
+tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_28),)
tools-y += squashfs lzma-old
else
@@ -89,5 +89,5 @@ $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(
$(curdir)/ := .config prereq
$(curdir)//install = $(1)/compile
-$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE))
+$(eval $(call stampfile,$(curdir),tools,install,,CONFIG_CCACHE CONFIG_powerpc CONFIG_GCC_VERSION_4_3 CONFIG_GCC_USE_GRAPHITE CONFIG_TARGET_orion))
$(eval $(call subdir,$(curdir)))