aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/image/Makefile4
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile13
2 files changed, 2 insertions, 15 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 2afd29b592..76e0abff1d 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -61,10 +61,9 @@ define Device/Default
IMAGES := sdcard.bin
IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
DEVICE_PROFILE :=
- DEVICE_NAME :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# $(1) = profile
# $(2) = image name
@@ -72,7 +71,6 @@ DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
define add_bcm2708
define Device/$(2)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index c5c982f5e1..f15b30b5f1 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -175,10 +175,9 @@ define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
KERNEL_INITRAMFS_IMAGE = $$(KERNEL_INITRAMFS_PREFIX).elf
DEVICE_PROFILE :=
- DEVICE_NAME :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# BCM33xx HCS devices: only generates ramdisks (unsupported bin images)
define Device/bcm33xxHcsRamdisk
@@ -313,7 +312,6 @@ define bcm33xxHcsRamdisk
define Device/$(2)
$$(Device/bcm33xxHcsRamdisk)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
HCS_MAGIC_BYTES := $(4)
HCS_REV_MIN := $(5)
@@ -329,7 +327,6 @@ define bcm63xxCfeRamdisk
define Device/$(2)
$$(Device/bcm63xxCfeRamdisk)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)
@@ -345,7 +342,6 @@ define bcm63xxCfe
define Device/$(2)
$$(Device/bcm63xxCfe)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -364,7 +360,6 @@ define bcm63xxCfeMultiFlash
define Device/$(2)
$$(Device/bcm63xxCfeMultiFlash)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -383,7 +378,6 @@ define bcm63xxCfeBc221
define Device/$(2)
$$(Device/bcm63xxCfeBc221)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -404,7 +398,6 @@ define bcm63xxCfeNetgear
define Device/$(2)
$$(Device/bcm63xxCfeNetgear)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -425,7 +418,6 @@ define bcm63xxCfeOld
define Device/$(2)
$$(Device/bcm63xxCfeOld)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -444,7 +436,6 @@ define bcm63xxCfeSpw303v
define Device/$(2)
$$(Device/bcm63xxCfeSpw303v)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -463,7 +454,6 @@ define bcm63xxCfeZyxel
define Device/$(2)
$$(Device/bcm63xxCfeZyxel)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -479,7 +469,6 @@ define bcm63xxRedBoot
define Device/$(2)
$$(Device/bcm63xxRedBoot)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)