aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/x86/64/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/kvm_guest/profiles/000-Generic.mk15
-rw-r--r--target/linux/x86/xen_domu/profiles/000-Generic.mk15
3 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/64/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/kvm_guest/profiles/000-Generic.mk b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/xen_domu/profiles/000-Generic.mk b/target/linux/x86/xen_domu/profiles/000-Generic.mk
new file mode 100644
index 0000000000..ccd125afa2
--- /dev/null
+++ b/target/linux/x86/xen_domu/profiles/000-Generic.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))