aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch b/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch
new file mode 100644
index 0000000000..1272e3dde2
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/800-oxnas-ehci.patch
@@ -0,0 +1,30 @@
+Index: linux-4.0-rc4/drivers/usb/host/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/usb/host/Kconfig
++++ linux-4.0-rc4/drivers/usb/host/Kconfig
+@@ -306,6 +306,13 @@ config USB_OCTEON_EHCI
+ USB 2.0 device support. All CN6XXX based chips with USB are
+ supported.
+
++config USB_EHCI_OXNAS
++ tristate "OXNAS EHCI Module"
++ depends on USB_EHCI_HCD && ARCH_OXNAS
++ select USB_EHCI_ROOT_HUB_TT
++ ---help---
++ Enable support for the OX820 SOC's on-chip EHCI controller.
++
+ endif # USB_EHCI_HCD
+
+ config USB_OXU210HP_HCD
+Index: linux-4.0-rc4/drivers/usb/host/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/usb/host/Makefile
++++ linux-4.0-rc4/drivers/usb/host/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
+ obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
+ obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
+ obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
++obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
+
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o