aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap/Makefile')
-rw-r--r--target/linux/omap/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/omap/Makefile b/target/linux/omap/Makefile
new file mode 100644
index 0000000000..3a62911ca3
--- /dev/null
+++ b/target/linux/omap/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2012-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap
+BOARDNAME:=TI OMAP3/4/AM33xx
+FEATURES:=usb targz audio display
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
+
+LINUX_VERSION:=3.3.8
+
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+KERNELNAME:="uImage"
+
+DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+
+DEVICE_TYPE=developerboard
+
+define Target/Description
+ TI OMAP boards
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))