aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta/le64
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/malta/le64')
-rw-r--r--target/linux/malta/le64/config-default14
-rw-r--r--target/linux/malta/le64/target.mk11
2 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/malta/le64/config-default b/target/linux/malta/le64/config-default
new file mode 100644
index 0000000000..1c13abf88e
--- /dev/null
+++ b/target/linux/malta/le64/config-default
@@ -0,0 +1,14 @@
+CONFIG_64BIT=y
+# CONFIG_32BIT is not set
+CONFIG_MIPS32_COMPAT=y
+CONFIG_MIPS32_O32=y
+CONFIG_MIPS32_N32=y
+# CONFIG_HUGETLBFS is not set
+# CONFIG_CPU_BIG_ENDIAN is not set
+CONFIG_CPU_LITTLE_ENDIAN=y
+CONFIG_CPU_MIPS64=y
+# CONFIG_CPU_MIPS32_R1 is not set
+# CONFIG_CPU_MIPS32_R2 is not set
+CONFIG_CPU_MIPS64_R1=y
+# CONFIG_CPU_MIPS64_R2 is not set
+CONFIG_CPU_SUPPORTS_64BIT_KERNEL=y
diff --git a/target/linux/malta/le64/target.mk b/target/linux/malta/le64/target.mk
new file mode 100644
index 0000000000..bd5c63619e
--- /dev/null
+++ b/target/linux/malta/le64/target.mk
@@ -0,0 +1,11 @@
+ARCH:=mips64el
+ARCH_PACKAGES:=malta_mipsel64
+SUBTARGET:=le64
+BOARDNAME:=Little Endian (64-bits)
+CFLAGS:=-Os -pipe -mips64 -mtune=mips64 -fno-caller-saves
+FEATURES:=ramdisk
+
+define Target/Description
+ Build LE firmware images for MIPS Malta CoreLV board running in
+ little-endian and 64-bits mode.
+endef