aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ipq806x/image/Makefile')
-rw-r--r--target/linux/ipq806x/image/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index f2c58b4c70..64e7f795c3 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -185,6 +185,18 @@ define Device/R7500
DEVICE_PACKAGES := ath10k-firmware-qca99x0
endef
+define Device/R7500v2
+ $(call Device/DniImage)
+ DEVICE_DTS := qcom-ipq8064-r7500v2
+ KERNEL_SIZE := 2097152
+ NETGEAR_BOARD_ID := R7500v2
+ NETGEAR_HW_ID := 29764958+0+128+512+3x3+4x4
+ BLOCKSIZE := 128KiB
+ PAGESIZE := 2048
+ BOARD_NAME := r7500v2
+ DEVICE_PACKAGES := ath10k-firmware-qca99x0
+endef
+
define Device/R7800
$(call Device/DniImage)
DEVICE_DTS := qcom-ipq8065-r7800
@@ -198,6 +210,6 @@ define Device/R7800
DEVICE_PACKAGES := ath10k-firmware-qca9984
endef
-TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7800
+TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800
$(eval $(call BuildImage))