aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.3/270-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-3.3/270-regmap_dynamic.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/target/linux/generic/patches-3.3/270-regmap_dynamic.patch b/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
deleted file mode 100644
index b1cfc8a628..0000000000
--- a/target/linux/generic/patches-3.3/270-regmap_dynamic.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/drivers/base/regmap/Kconfig
-+++ b/drivers/base/regmap/Kconfig
-@@ -3,16 +3,18 @@
- # subsystems should select the appropriate symbols.
-
- config REGMAP
-- default y if (REGMAP_I2C || REGMAP_SPI)
- select LZO_COMPRESS
- select LZO_DECOMPRESS
-- bool
-+ tristate "Regmap"
-
- config REGMAP_I2C
-- tristate
-+ select REGMAP
-+ tristate "Regmap I2C"
-
- config REGMAP_SPI
-- tristate
-+ select REGMAP
-+ depends on SPI_MASTER
-+ tristate "Regmap SPI"
-
- config REGMAP_IRQ
- bool
---- a/drivers/base/regmap/Makefile
-+++ b/drivers/base/regmap/Makefile
-@@ -1,6 +1,8 @@
--obj-$(CONFIG_REGMAP) += regmap.o regcache.o
--obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o
--obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
-+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o
-+ifdef CONFIG_DEBUG_FS
-+regmap-core-objs += regmap-debugfs.o
-+endif
-+obj-$(CONFIG_REGMAP) += regmap-core.o
- obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
- obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
- obj-$(CONFIG_REGMAP_IRQ) += regmap-irq.o
---- a/drivers/base/regmap/regmap.c
-+++ b/drivers/base/regmap/regmap.c
-@@ -13,6 +13,7 @@
- #include <linux/slab.h>
- #include <linux/module.h>
- #include <linux/mutex.h>
-+#include <linux/module.h>
- #include <linux/err.h>
-
- #define CREATE_TRACE_POINTS
-@@ -679,3 +680,5 @@ static int __init regmap_initcall(void)
- return 0;
- }
- postcore_initcall(regmap_initcall);
-+
-+MODULE_LICENSE("GPL");