aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.18')
-rw-r--r--target/linux/generic/patches-3.18/724-phy_ar8216.patch2
-rw-r--r--target/linux/generic/patches-3.18/725-phy_rtl8306.patch2
-rw-r--r--target/linux/generic/patches-3.18/726-phy_rtl8366.patch2
-rw-r--r--target/linux/generic/patches-3.18/733-phy_mvsw6171.patch2
4 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic/patches-3.18/724-phy_ar8216.patch b/target/linux/generic/patches-3.18/724-phy_ar8216.patch
index 869081e883..acb2df8f83 100644
--- a/target/linux/generic/patches-3.18/724-phy_ar8216.patch
+++ b/target/linux/generic/patches-3.18/724-phy_ar8216.patch
@@ -18,7 +18,7 @@
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
-+obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
diff --git a/target/linux/generic/patches-3.18/725-phy_rtl8306.patch b/target/linux/generic/patches-3.18/725-phy_rtl8306.patch
index 6629700d78..78ac6ce98a 100644
--- a/target/linux/generic/patches-3.18/725-phy_rtl8306.patch
+++ b/target/linux/generic/patches-3.18/725-phy_rtl8306.patch
@@ -16,7 +16,7 @@
@@ -23,6 +23,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
+obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
diff --git a/target/linux/generic/patches-3.18/726-phy_rtl8366.patch b/target/linux/generic/patches-3.18/726-phy_rtl8366.patch
index 833bb22ab8..4a4a4acee0 100644
--- a/target/linux/generic/patches-3.18/726-phy_rtl8366.patch
+++ b/target/linux/generic/patches-3.18/726-phy_rtl8366.patch
@@ -35,7 +35,7 @@
+++ b/drivers/net/phy/Makefile
@@ -24,6 +24,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
diff --git a/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch b/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch
index 0df13fe766..0221fc31cd 100644
--- a/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch
+++ b/target/linux/generic/patches-3.18/733-phy_mvsw6171.patch
@@ -20,4 +20,4 @@
+obj-$(CONFIG_MVSW6171_PHY) += mvsw6171.o
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o