aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch b/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch
new file mode 100644
index 0000000000..a70f81828c
--- /dev/null
+++ b/target/linux/generic/patches-3.18/403-mtd-hook-mtdsplit-to-Kbuild.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -32,6 +32,11 @@ config MTD_UIMAGE_SPLIT
+ depends on MTD_SPLIT_FIRMWARE
+ default y
+
++config MTD_SPLIT
++ def_bool n
++ help
++ Generic MTD split support.
++
+ endmenu
+
+ config MTD_TESTS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -6,6 +6,8 @@
+ obj-$(CONFIG_MTD) += mtd.o
+ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+
++mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o