aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch')
-rw-r--r--target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
index 3d3c6253f2..49986da1b2 100644
--- a/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
+++ b/target/linux/generic/patches-3.10/643-bridge_remove_ipv6_dependency.patch
@@ -1,6 +1,6 @@
--- a/include/net/addrconf.h
+++ b/include/net/addrconf.h
-@@ -96,6 +96,12 @@ extern void addrconf_join_solict(struc
+@@ -99,6 +99,12 @@ extern void addrconf_join_solict(struc
extern void addrconf_leave_solict(struct inet6_dev *idev,
const struct in6_addr *addr);
@@ -25,7 +25,7 @@
Ethernet bridge, which means that the different Ethernet segments it
--- a/net/ipv6/Makefile
+++ b/net/ipv6/Makefile
-@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
+@@ -44,3 +44,4 @@ obj-y += addrconf_core.o exthdrs_core.o
obj-$(CONFIG_INET) += output_core.o protocol.o $(ipv6-offload)
obj-$(subst m,y,$(CONFIG_IPV6)) += inet6_hashtables.o
@@ -47,9 +47,9 @@
}
-EXPORT_SYMBOL(ipv6_dev_get_saddr);
- int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
- unsigned char banned_flags)
-@@ -5137,6 +5136,9 @@ int __init addrconf_init(void)
+ int __ipv6_get_lladdr(struct inet6_dev *idev, struct in6_addr *addr,
+ unsigned char banned_flags)
+@@ -5145,6 +5144,9 @@ int __init addrconf_init(void)
ipv6_addr_label_rtnl_register();
@@ -59,7 +59,7 @@
return 0;
errout:
rtnl_af_unregister(&inet6_ops);
-@@ -5155,6 +5157,9 @@ void addrconf_cleanup(void)
+@@ -5163,6 +5165,9 @@ void addrconf_cleanup(void)
struct net_device *dev;
int i;