aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.32/420-gpiodev.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.32/420-gpiodev.patch')
-rw-r--r--target/linux/generic/patches-2.6.32/420-gpiodev.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.32/420-gpiodev.patch b/target/linux/generic/patches-2.6.32/420-gpiodev.patch
new file mode 100644
index 0000000000..7e4b85b25b
--- /dev/null
+++ b/target/linux/generic/patches-2.6.32/420-gpiodev.patch
@@ -0,0 +1,27 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1029,6 +1029,14 @@ config CS5535_GPIO
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
++
+ config RAW_DRIVER
+ tristate "RAW driver (/dev/raw/rawN)"
+ depends on BLOCK
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -96,6 +96,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
+