aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.31/400-ledtrig_morse.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.31/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.31/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.31/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.31/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..9e3ddec03b
--- /dev/null
+++ b/target/linux/generic/patches-2.6.31/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -297,4 +297,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o