aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.25/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/generic/patches-2.6.25/010-disable_old_squashfs_compatibility.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.25/010-disable_old_squashfs_compatibility.patch b/target/linux/generic/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..01e27573bc
--- /dev/null
+++ b/target/linux/generic/patches-2.6.25/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,19 @@
+--- a/fs/squashfs/Makefile
++++ b/fs/squashfs/Makefile
+@@ -4,4 +4,3 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+--- a/fs/squashfs/squashfs.h
++++ b/fs/squashfs/squashfs.h
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)