aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch26
1 files changed, 9 insertions, 17 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch b/target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch
index 8a963c2842..205ede2b51 100644
--- a/target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/600-eeprom_93cx6.patch
@@ -12,11 +12,9 @@ Signed-off-by: Michael Wu <flamingice@sourmilk.net>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
-Index: linux-2.6.22.19/drivers/misc/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/drivers/misc/Kconfig
-+++ linux-2.6.22.19/drivers/misc/Kconfig
-@@ -34,6 +34,11 @@ config PHANTOM
+--- a/drivers/misc/Kconfig
++++ b/drivers/misc/Kconfig
+@@ -34,6 +34,11 @@
If you choose to build module, its name will be phantom. If unsure,
say N here.
@@ -28,25 +26,21 @@ Index: linux-2.6.22.19/drivers/misc/Kconfig
If unsure, say N.
-@@ -187,5 +192,4 @@ config THINKPAD_ACPI_BAY
+@@ -187,5 +192,4 @@
If you are not sure, say Y here.
-
endmenu
-Index: linux-2.6.22.19/drivers/misc/Makefile
-===================================================================
---- linux-2.6.22.19.orig/drivers/misc/Makefile
-+++ linux-2.6.22.19/drivers/misc/Makefile
-@@ -14,3 +14,4 @@ obj-$(CONFIG_PHANTOM) += phantom.o
+--- a/drivers/misc/Makefile
++++ b/drivers/misc/Makefile
+@@ -14,3 +14,4 @@
obj-$(CONFIG_SGI_IOC4) += ioc4.o
obj-$(CONFIG_SONY_LAPTOP) += sony-laptop.o
obj-$(CONFIG_THINKPAD_ACPI) += thinkpad_acpi.o
+obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
-Index: linux-2.6.22.19/drivers/misc/eeprom_93cx6.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/drivers/misc/eeprom_93cx6.c
++++ b/drivers/misc/eeprom_93cx6.c
@@ -0,0 +1,229 @@
+/*
+ Copyright (C) 2004 - 2006 rt2x00 SourceForge Project
@@ -277,10 +271,8 @@ Index: linux-2.6.22.19/drivers/misc/eeprom_93cx6.c
+}
+EXPORT_SYMBOL_GPL(eeprom_93cx6_multiread);
+
-Index: linux-2.6.22.19/include/linux/eeprom_93cx6.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/eeprom_93cx6.h
++++ b/include/linux/eeprom_93cx6.h
@@ -0,0 +1,72 @@
+/*
+ Copyright (C) 2004 - 2006 rt2x00 SourceForge Project