aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch110
1 files changed, 39 insertions, 71 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch b/target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch
index b7aefab3d8..17b4569a85 100644
--- a/target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch
+++ b/target/linux/generic-2.6/patches-2.6.22/150-netfilter_imq.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.22.19/drivers/net/imq.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/drivers/net/imq.c
++++ b/drivers/net/imq.c
@@ -0,0 +1,402 @@
+/*
+ * Pseudo-driver for the intermediate queue device.
@@ -405,11 +403,9 @@ Index: linux-2.6.22.19/drivers/net/imq.c
+MODULE_AUTHOR("http://www.linuximq.net");
+MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.22.19/drivers/net/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/drivers/net/Kconfig
-+++ linux-2.6.22.19/drivers/net/Kconfig
-@@ -96,6 +96,129 @@ config EQUALIZER
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -96,6 +96,129 @@
To compile this driver as a module, choose M here: the module
will be called eql. If unsure, say N.
@@ -539,11 +535,9 @@ Index: linux-2.6.22.19/drivers/net/Kconfig
config TUN
tristate "Universal TUN/TAP device driver support"
select CRC32
-Index: linux-2.6.22.19/drivers/net/Makefile
-===================================================================
---- linux-2.6.22.19.orig/drivers/net/Makefile
-+++ linux-2.6.22.19/drivers/net/Makefile
-@@ -124,6 +124,7 @@ obj-$(CONFIG_SLIP) += slip.o
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -124,6 +124,7 @@
obj-$(CONFIG_SLHC) += slhc.o
obj-$(CONFIG_DUMMY) += dummy.o
@@ -551,10 +545,8 @@ Index: linux-2.6.22.19/drivers/net/Makefile
obj-$(CONFIG_IFB) += ifb.o
obj-$(CONFIG_DE600) += de600.o
obj-$(CONFIG_DE620) += de620.o
-Index: linux-2.6.22.19/include/linux/imq.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/imq.h
++++ b/include/linux/imq.h
@@ -0,0 +1,9 @@
+#ifndef _IMQ_H
+#define _IMQ_H
@@ -565,10 +557,8 @@ Index: linux-2.6.22.19/include/linux/imq.h
+#define IMQ_F_ENQUEUE 0x80
+
+#endif /* _IMQ_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_IMQ.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_IMQ.h
++++ b/include/linux/netfilter_ipv4/ipt_IMQ.h
@@ -0,0 +1,8 @@
+#ifndef _IPT_IMQ_H
+#define _IPT_IMQ_H
@@ -578,10 +568,8 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv4/ipt_IMQ.h
+};
+
+#endif /* _IPT_IMQ_H */
-Index: linux-2.6.22.19/include/linux/netfilter_ipv6/ip6t_IMQ.h
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/include/linux/netfilter_ipv6/ip6t_IMQ.h
++++ b/include/linux/netfilter_ipv6/ip6t_IMQ.h
@@ -0,0 +1,8 @@
+#ifndef _IP6T_IMQ_H
+#define _IP6T_IMQ_H
@@ -591,11 +579,9 @@ Index: linux-2.6.22.19/include/linux/netfilter_ipv6/ip6t_IMQ.h
+};
+
+#endif /* _IP6T_IMQ_H */
-Index: linux-2.6.22.19/include/linux/skbuff.h
-===================================================================
---- linux-2.6.22.19.orig/include/linux/skbuff.h
-+++ linux-2.6.22.19/include/linux/skbuff.h
-@@ -285,6 +285,10 @@ struct sk_buff {
+--- a/include/linux/skbuff.h
++++ b/include/linux/skbuff.h
+@@ -285,6 +285,10 @@
struct nf_conntrack *nfct;
struct sk_buff *nfct_reasm;
#endif
@@ -606,10 +592,8 @@ Index: linux-2.6.22.19/include/linux/skbuff.h
#ifdef CONFIG_BRIDGE_NETFILTER
struct nf_bridge_info *nf_bridge;
#endif
-Index: linux-2.6.22.19/net/core/dev.c
-===================================================================
---- linux-2.6.22.19.orig/net/core/dev.c
-+++ linux-2.6.22.19/net/core/dev.c
+--- a/net/core/dev.c
++++ b/net/core/dev.c
@@ -94,6 +94,9 @@
#include <linux/skbuff.h>
#include <net/sock.h>
@@ -620,7 +604,7 @@ Index: linux-2.6.22.19/net/core/dev.c
#include <linux/proc_fs.h>
#include <linux/seq_file.h>
#include <linux/stat.h>
-@@ -1404,6 +1407,9 @@ int dev_hard_start_xmit(struct sk_buff *
+@@ -1404,6 +1407,9 @@
{
if (likely(!skb->next)) {
if (!list_empty(&ptype_all))
@@ -630,11 +614,9 @@ Index: linux-2.6.22.19/net/core/dev.c
dev_queue_xmit_nit(skb, dev);
if (netif_needs_gso(dev, skb)) {
-Index: linux-2.6.22.19/net/core/skbuff.c
-===================================================================
---- linux-2.6.22.19.orig/net/core/skbuff.c
-+++ linux-2.6.22.19/net/core/skbuff.c
-@@ -419,6 +419,10 @@ struct sk_buff *skb_clone(struct sk_buff
+--- a/net/core/skbuff.c
++++ b/net/core/skbuff.c
+@@ -419,6 +419,10 @@
C(pkt_type);
C(ip_summed);
C(priority);
@@ -645,7 +627,7 @@ Index: linux-2.6.22.19/net/core/skbuff.c
#if defined(CONFIG_IP_VS) || defined(CONFIG_IP_VS_MODULE)
C(ipvs_property);
#endif
-@@ -485,6 +489,10 @@ static void copy_skb_header(struct sk_bu
+@@ -485,6 +489,10 @@
#if defined(CONFIG_IP_VS) || defined(CONFIG_IP_VS_MODULE)
new->ipvs_property = old->ipvs_property;
#endif
@@ -656,10 +638,8 @@ Index: linux-2.6.22.19/net/core/skbuff.c
#ifdef CONFIG_NET_SCHED
#ifdef CONFIG_NET_CLS_ACT
new->tc_verd = old->tc_verd;
-Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_IMQ.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv4/netfilter/ipt_IMQ.c
++++ b/net/ipv4/netfilter/ipt_IMQ.c
@@ -0,0 +1,69 @@
+/*
+ * This target marks packets to be enqueued to an imq device
@@ -730,11 +710,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/ipt_IMQ.c
+MODULE_AUTHOR("http://www.linuximq.net");
+MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.22.19/net/ipv4/netfilter/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/net/ipv4/netfilter/Kconfig
-+++ linux-2.6.22.19/net/ipv4/netfilter/Kconfig
-@@ -333,6 +333,17 @@ config IP_NF_MANGLE
+--- a/net/ipv4/netfilter/Kconfig
++++ b/net/ipv4/netfilter/Kconfig
+@@ -333,6 +333,17 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -752,11 +730,9 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/Kconfig
config IP_NF_TARGET_TOS
tristate "TOS target support"
depends on IP_NF_MANGLE
-Index: linux-2.6.22.19/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.6.22.19.orig/net/ipv4/netfilter/Makefile
-+++ linux-2.6.22.19/net/ipv4/netfilter/Makefile
-@@ -57,6 +57,7 @@ obj-$(CONFIG_IP_NF_MATCH_IPP2P) += ipt_i
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -57,6 +57,7 @@
obj-$(CONFIG_IP_NF_TARGET_REJECT) += ipt_REJECT.o
obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TOS.o
obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
@@ -764,10 +740,8 @@ Index: linux-2.6.22.19/net/ipv4/netfilter/Makefile
obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) += ipt_MASQUERADE.o
obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o
obj-$(CONFIG_IP_NF_TARGET_NETMAP) += ipt_NETMAP.o
-Index: linux-2.6.22.19/net/ipv6/netfilter/ip6t_IMQ.c
-===================================================================
--- /dev/null
-+++ linux-2.6.22.19/net/ipv6/netfilter/ip6t_IMQ.c
++++ b/net/ipv6/netfilter/ip6t_IMQ.c
@@ -0,0 +1,69 @@
+/*
+ * This target marks packets to be enqueued to an imq device
@@ -838,11 +812,9 @@ Index: linux-2.6.22.19/net/ipv6/netfilter/ip6t_IMQ.c
+MODULE_AUTHOR("http://www.linuximq.net");
+MODULE_DESCRIPTION("Pseudo-driver for the intermediate queue device. See http://www.linuximq.net/ for more information.");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.22.19/net/ipv6/netfilter/Kconfig
-===================================================================
---- linux-2.6.22.19.orig/net/ipv6/netfilter/Kconfig
-+++ linux-2.6.22.19/net/ipv6/netfilter/Kconfig
-@@ -173,6 +173,15 @@ config IP6_NF_MANGLE
+--- a/net/ipv6/netfilter/Kconfig
++++ b/net/ipv6/netfilter/Kconfig
+@@ -173,6 +173,15 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -858,11 +830,9 @@ Index: linux-2.6.22.19/net/ipv6/netfilter/Kconfig
config IP6_NF_TARGET_HL
tristate 'HL (hoplimit) target support'
depends on IP6_NF_MANGLE
-Index: linux-2.6.22.19/net/ipv6/netfilter/Makefile
-===================================================================
---- linux-2.6.22.19.orig/net/ipv6/netfilter/Makefile
-+++ linux-2.6.22.19/net/ipv6/netfilter/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_IP6_NF_MATCH_EUI64) += ip6t
+--- a/net/ipv6/netfilter/Makefile
++++ b/net/ipv6/netfilter/Makefile
+@@ -13,6 +13,7 @@
obj-$(CONFIG_IP6_NF_MATCH_OWNER) += ip6t_owner.o
obj-$(CONFIG_IP6_NF_FILTER) += ip6table_filter.o
obj-$(CONFIG_IP6_NF_MANGLE) += ip6table_mangle.o
@@ -870,11 +840,9 @@ Index: linux-2.6.22.19/net/ipv6/netfilter/Makefile
obj-$(CONFIG_IP6_NF_TARGET_HL) += ip6t_HL.o
obj-$(CONFIG_IP6_NF_QUEUE) += ip6_queue.o
obj-$(CONFIG_IP6_NF_TARGET_LOG) += ip6t_LOG.o
-Index: linux-2.6.22.19/net/sched/sch_generic.c
-===================================================================
---- linux-2.6.22.19.orig/net/sched/sch_generic.c
-+++ linux-2.6.22.19/net/sched/sch_generic.c
-@@ -77,7 +77,6 @@ void qdisc_unlock_tree(struct net_device
+--- a/net/sched/sch_generic.c
++++ b/net/sched/sch_generic.c
+@@ -77,7 +77,6 @@
NOTE: Called under dev->queue_lock with locally disabled BH.
*/
@@ -882,7 +850,7 @@ Index: linux-2.6.22.19/net/sched/sch_generic.c
static inline int qdisc_restart(struct net_device *dev)
{
struct Qdisc *q = dev->qdisc;
-@@ -177,6 +176,11 @@ out:
+@@ -177,6 +176,11 @@
return q->q.qlen;
}
@@ -894,7 +862,7 @@ Index: linux-2.6.22.19/net/sched/sch_generic.c
void __qdisc_run(struct net_device *dev)
{
do {
-@@ -608,3 +612,4 @@ EXPORT_SYMBOL(qdisc_destroy);
+@@ -608,3 +612,4 @@
EXPORT_SYMBOL(qdisc_reset);
EXPORT_SYMBOL(qdisc_lock_tree);
EXPORT_SYMBOL(qdisc_unlock_tree);