aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk')
-rw-r--r--target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk b/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
index 56a505a90e..cd6b10b373 100644
--- a/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
+++ b/target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
@@ -1,18 +1,19 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define Profile/Broadcom-ath5k
- NAME:=Atheros WiFi (ath5k)
- PACKAGES:=kmod-b44 kmod-ath5k
+ NAME:=Broadcom SoC, all Ethernet, Atheros WiFi (ath5k)
+ PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-ath5k
endef
-define Profile/Atheros/Description
- Package set compatible with hardware using Atheros WiFi cards and
- b44 Ethernet driver.
+define Profile/Broadcom-ath5k/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+ b44, tg3 or bgmac Ethernet driver.
endef
$(eval $(call Profile,Broadcom-ath5k))