aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.10/0118-ASoC-Add-support-for-PCM5102A-codec.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-3.10/0118-ASoC-Add-support-for-PCM5102A-codec.patch')
-rw-r--r--target/linux/brcm2708/patches-3.10/0118-ASoC-Add-support-for-PCM5102A-codec.patch130
1 files changed, 0 insertions, 130 deletions
diff --git a/target/linux/brcm2708/patches-3.10/0118-ASoC-Add-support-for-PCM5102A-codec.patch b/target/linux/brcm2708/patches-3.10/0118-ASoC-Add-support-for-PCM5102A-codec.patch
deleted file mode 100644
index 587135d0da..0000000000
--- a/target/linux/brcm2708/patches-3.10/0118-ASoC-Add-support-for-PCM5102A-codec.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-From 8f5751798e712bae5a2ff370368745a3464b2027 Mon Sep 17 00:00:00 2001
-From: Florian Meier <florian.meier@koalo.de>
-Date: Fri, 22 Nov 2013 14:59:51 +0100
-Subject: [PATCH 118/196] ASoC: Add support for PCM5102A codec
-
-Some definitions to support the PCM5102A codec
-by Texas Instruments.
-
-Signed-off-by: Florian Meier <florian.meier@koalo.de>
----
- sound/soc/codecs/Kconfig | 4 +++
- sound/soc/codecs/Makefile | 2 ++
- sound/soc/codecs/pcm5102a.c | 63 +++++++++++++++++++++++++++++++++++++++++++++
- 3 files changed, 69 insertions(+)
- create mode 100644 sound/soc/codecs/pcm5102a.c
-
-diff --git a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
-index 2f45f00..7c43413 100644
---- a/sound/soc/codecs/Kconfig
-+++ b/sound/soc/codecs/Kconfig
-@@ -55,6 +55,7 @@ config SND_SOC_ALL_CODECS
- select SND_SOC_ML26124 if I2C
- select SND_SOC_OMAP_HDMI_CODEC if OMAP4_DSS_HDMI
- select SND_SOC_PCM3008
-+ select SND_SOC_PCM5102A
- select SND_SOC_RT5631 if I2C
- select SND_SOC_SGTL5000 if I2C
- select SND_SOC_SI476X if MFD_SI476X_CORE
-@@ -293,6 +294,9 @@ config SND_SOC_OMAP_HDMI_CODEC
- config SND_SOC_PCM3008
- tristate
-
-+config SND_SOC_PCM5102A
-+ tristate
-+
- config SND_SOC_RT5631
- tristate
-
-diff --git a/sound/soc/codecs/Makefile b/sound/soc/codecs/Makefile
-index b9e41c9..0677eb5 100644
---- a/sound/soc/codecs/Makefile
-+++ b/sound/soc/codecs/Makefile
-@@ -43,6 +43,7 @@ snd-soc-mc13783-objs := mc13783.o
- snd-soc-ml26124-objs := ml26124.o
- snd-soc-omap-hdmi-codec-objs := omap-hdmi.o
- snd-soc-pcm3008-objs := pcm3008.o
-+snd-soc-pcm5102a-objs := pcm5102a.o
- snd-soc-rt5631-objs := rt5631.o
- snd-soc-sgtl5000-objs := sgtl5000.o
- snd-soc-alc5623-objs := alc5623.o
-@@ -170,6 +171,7 @@ obj-$(CONFIG_SND_SOC_MC13783) += snd-soc-mc13783.o
- obj-$(CONFIG_SND_SOC_ML26124) += snd-soc-ml26124.o
- obj-$(CONFIG_SND_SOC_OMAP_HDMI_CODEC) += snd-soc-omap-hdmi-codec.o
- obj-$(CONFIG_SND_SOC_PCM3008) += snd-soc-pcm3008.o
-+obj-$(CONFIG_SND_SOC_PCM5102A) += snd-soc-pcm5102a.o
- obj-$(CONFIG_SND_SOC_RT5631) += snd-soc-rt5631.o
- obj-$(CONFIG_SND_SOC_SGTL5000) += snd-soc-sgtl5000.o
- obj-$(CONFIG_SND_SOC_SIGMADSP) += snd-soc-sigmadsp.o
-diff --git a/sound/soc/codecs/pcm5102a.c b/sound/soc/codecs/pcm5102a.c
-new file mode 100644
-index 0000000..126f1e9
---- /dev/null
-+++ b/sound/soc/codecs/pcm5102a.c
-@@ -0,0 +1,63 @@
-+/*
-+ * Driver for the PCM5102A codec
-+ *
-+ * Author: Florian Meier <florian.meier@koalo.de>
-+ * Copyright 2013
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * version 2 as published by the Free Software Foundation.
-+ *
-+ * This program is distributed in the hope that it will be useful, but
-+ * WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * General Public License for more details.
-+ */
-+
-+
-+#include <linux/init.h>
-+#include <linux/module.h>
-+#include <linux/platform_device.h>
-+
-+#include <sound/soc.h>
-+
-+static struct snd_soc_dai_driver pcm5102a_dai = {
-+ .name = "pcm5102a-hifi",
-+ .playback = {
-+ .channels_min = 2,
-+ .channels_max = 2,
-+ .rates = SNDRV_PCM_RATE_8000_192000,
-+ .formats = SNDRV_PCM_FMTBIT_S16_LE |
-+ SNDRV_PCM_FMTBIT_S24_LE |
-+ SNDRV_PCM_FMTBIT_S32_LE
-+ },
-+};
-+
-+static struct snd_soc_codec_driver soc_codec_dev_pcm5102a;
-+
-+static int pcm5102a_probe(struct platform_device *pdev)
-+{
-+ return snd_soc_register_codec(&pdev->dev, &soc_codec_dev_pcm5102a,
-+ &pcm5102a_dai, 1);
-+}
-+
-+static int pcm5102a_remove(struct platform_device *pdev)
-+{
-+ snd_soc_unregister_codec(&pdev->dev);
-+ return 0;
-+}
-+
-+static struct platform_driver pcm5102a_codec_driver = {
-+ .probe = pcm5102a_probe,
-+ .remove = pcm5102a_remove,
-+ .driver = {
-+ .name = "pcm5102a-codec",
-+ .owner = THIS_MODULE,
-+ },
-+};
-+
-+module_platform_driver(pcm5102a_codec_driver);
-+
-+MODULE_DESCRIPTION("ASoC PCM5102A codec driver");
-+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
-+MODULE_LICENSE("GPL v2");
---
-1.9.1
-