aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch')
-rw-r--r--target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch21
1 files changed, 17 insertions, 4 deletions
diff --git a/target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch b/target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch
index 4f1f5d9429..e2faf2087b 100644
--- a/target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch
+++ b/target/linux/brcm2708/patches-3.10/0098-wifi-add-patches-from-3.6.y-tree-to-make-rtl8192cu-w.patch
@@ -1,7 +1,7 @@
-From 1c4544175663c38eb22b9095ce75c31f2d6c6e18 Mon Sep 17 00:00:00 2001
+From 0682247a80d24b2613d4a89b396371ac7fcf3214 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Sat, 9 Nov 2013 13:32:03 +0000
-Subject: [PATCH 098/174] wifi: add patches from 3.6.y tree to make rtl8192cu
+Subject: [PATCH 098/196] wifi: add patches from 3.6.y tree to make rtl8192cu
work
wifi: add missing patch from 3.6.y tree to disable debug
@@ -13,6 +13,8 @@ wifi: add missing patch from 3.6.y tree to disable debug
drivers/net/wireless/rtl8192cu/os_dep/linux/usb_intf.c | 1 +
5 files changed, 23 insertions(+), 3 deletions(-)
+diff --git a/drivers/net/wireless/rtl8192cu/Kconfig b/drivers/net/wireless/rtl8192cu/Kconfig
+index bee5ed6..ef46361 100644
--- a/drivers/net/wireless/rtl8192cu/Kconfig
+++ b/drivers/net/wireless/rtl8192cu/Kconfig
@@ -1,6 +1,8 @@
@@ -25,6 +27,8 @@ wifi: add missing patch from 3.6.y tree to disable debug
- Help message of RTL8192CU
+ Enable wireless network adapters based on Realtek RTL8192C chipset family, such as EDUP nano series
+diff --git a/drivers/net/wireless/rtl8192cu/Makefile b/drivers/net/wireless/rtl8192cu/Makefile
+index c399011..f85c59f 100644
--- a/drivers/net/wireless/rtl8192cu/Makefile
+++ b/drivers/net/wireless/rtl8192cu/Makefile
@@ -38,7 +38,7 @@ CONFIG_RTL8192CU_REDEFINE_1X1 = n
@@ -47,6 +51,8 @@ wifi: add missing patch from 3.6.y tree to disable debug
ifneq ($(USER_MODULE_NAME),)
MODULE_NAME := $(USER_MODULE_NAME)
endif
+diff --git a/drivers/net/wireless/rtl8192cu/include/autoconf.h b/drivers/net/wireless/rtl8192cu/include/autoconf.h
+index 12294df..1341ff0 100644
--- a/drivers/net/wireless/rtl8192cu/include/autoconf.h
+++ b/drivers/net/wireless/rtl8192cu/include/autoconf.h
@@ -296,7 +296,7 @@
@@ -58,6 +64,8 @@ wifi: add missing patch from 3.6.y tree to disable debug
#define CONFIG_PROC_DEBUG 1
+diff --git a/drivers/net/wireless/rtl8192cu/os_dep/linux/os_intfs.c b/drivers/net/wireless/rtl8192cu/os_dep/linux/os_intfs.c
+index 82dee6d..b0bf0e9 100644
--- a/drivers/net/wireless/rtl8192cu/os_dep/linux/os_intfs.c
+++ b/drivers/net/wireless/rtl8192cu/os_dep/linux/os_intfs.c
@@ -277,6 +277,18 @@ static int rtw_proc_cnt = 0;
@@ -79,7 +87,7 @@ wifi: add missing patch from 3.6.y tree to disable debug
void rtw_proc_init_one(struct net_device *dev)
{
struct proc_dir_entry *dir_dev = NULL;
-@@ -751,6 +763,7 @@ void rtw_proc_remove_one(struct net_devi
+@@ -751,6 +763,7 @@ void rtw_proc_remove_one(struct net_device *dev)
}
}
}
@@ -87,9 +95,11 @@ wifi: add missing patch from 3.6.y tree to disable debug
#endif
uint loadparam( _adapter *padapter, _nic_hdl pnetdev);
+diff --git a/drivers/net/wireless/rtl8192cu/os_dep/linux/usb_intf.c b/drivers/net/wireless/rtl8192cu/os_dep/linux/usb_intf.c
+index 4c1089a..baccb59 100644
--- a/drivers/net/wireless/rtl8192cu/os_dep/linux/usb_intf.c
+++ b/drivers/net/wireless/rtl8192cu/os_dep/linux/usb_intf.c
-@@ -138,6 +138,7 @@ static void rtw_dev_remove(struct usb_in
+@@ -138,6 +138,7 @@ static void rtw_dev_remove(struct usb_interface *pusb_intf);
{USB_DEVICE(0x2001, 0x3307)},/* D-Link - Cameo */ \
{USB_DEVICE(0x2001, 0x330A)},/* D-Link - Alpha */ \
{USB_DEVICE(0x2001, 0x3309)},/* D-Link - Alpha */ \
@@ -97,3 +107,6 @@ wifi: add missing patch from 3.6.y tree to disable debug
{USB_DEVICE(0x0586, 0x341F)},/* Zyxel - Abocom */ \
{USB_DEVICE(0x7392, 0x7822)},/* Edimax - Edimax */ \
{USB_DEVICE(0x2019, 0xAB2B)},/* Planex - Abocom */ \
+--
+1.9.1
+