aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/image/Makefile')
-rw-r--r--target/linux/brcm2708/image/Makefile42
1 files changed, 24 insertions, 18 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 35f51204f0..e7089c6a19 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2012-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -42,39 +42,45 @@ define Build/sdcard-img
$(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
-### Devices ###
+### Device macros ###
define Device/Default
FILESYSTEMS := ext4
+ PROFILES = Default $$(DEVICE_PROFILE)
KERNEL := kernel-bin | kernel-img
IMAGES := sdcard.img
IMAGE/sdcard.img := boot-img | sdcard-img
+ DEVICE_PROFILE :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
-define Device/rpi
- DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
- DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
+# $(1) = profile
+# $(2) = image name
+# $(3) = dts
+define bcm27xx
+ define Device/$(2)
+ DEVICE_PROFILE := $(1)
+ DEVICE_DTS := $(3)
+ endef
+ TARGET_DEVICES += $(2)
endef
+
+### BCM2708/BCM2835 ###
ifeq ($(SUBTARGET),bcm2708)
- TARGET_DEVICES += rpi
+ # Raspberry Pi Models B/B+/CM
+ $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
endif
-define Device/rpi-2
- DEVICE_TITLE := Raspberry Pi 2 B
- DEVICE_DTS := bcm2709-rpi-2-b
-endef
+### BCM2709/BCM2836 ###
ifeq ($(SUBTARGET),bcm2709)
- TARGET_DEVICES += rpi-2
+ # Raspberry Pi 2 Model B
+ $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
endif
-define Device/rpi-3
- DEVICE_TITLE := Raspberry Pi 3 B
- DEVICE_DTS := bcm2710-rpi-3-b
- DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
-endef
+### BCM2710/BCM2837 ###
ifeq ($(SUBTARGET),bcm2710)
- TARGET_DEVICES += rpi-3
+ # Raspberry Pi 3 Model B
+ $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
endif
$(eval $(call BuildImage))