aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/bcm2710
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/bcm2710')
-rw-r--r--target/linux/brcm2708/bcm2710/config-4.45
-rw-r--r--target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk15
2 files changed, 5 insertions, 15 deletions
diff --git a/target/linux/brcm2708/bcm2710/config-4.4 b/target/linux/brcm2708/bcm2710/config-4.4
index 8614c8f828..da9f668c15 100644
--- a/target/linux/brcm2708/bcm2710/config-4.4
+++ b/target/linux/brcm2708/bcm2710/config-4.4
@@ -283,6 +283,7 @@ CONFIG_NR_CPUS=4
CONFIG_OABI_COMPAT=y
CONFIG_OF=y
CONFIG_OF_ADDRESS=y
+CONFIG_OF_CONFIGFS=y
CONFIG_OF_EARLY_FLATTREE=y
CONFIG_OF_FLATTREE=y
CONFIG_OF_GPIO=y
@@ -303,6 +304,9 @@ CONFIG_PINCTRL_BCM2835=y
CONFIG_PM=y
CONFIG_PM_CLK=y
# CONFIG_PM_DEBUG is not set
+CONFIG_PM_GENERIC_DOMAINS=y
+CONFIG_PM_GENERIC_DOMAINS_OF=y
+CONFIG_PM_GENERIC_DOMAINS_SLEEP=y
CONFIG_PM_SLEEP=y
CONFIG_PM_SLEEP_SMP=y
CONFIG_POWER_SUPPLY=y
@@ -312,6 +316,7 @@ CONFIG_PWM=y
CONFIG_PWM_BCM2835=y
CONFIG_PWM_SYSFS=y
CONFIG_RASPBERRYPI_FIRMWARE=y
+CONFIG_RASPBERRYPI_POWER=y
CONFIG_RATIONAL=y
CONFIG_RAW_DRIVER=y
CONFIG_RCU_STALL_COMMON=y
diff --git a/target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk b/target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk
deleted file mode 100644
index c39cf5257b..0000000000
--- a/target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RaspberryPi_3
- NAME:=Raspberry Pi 3 Model B
- PACKAGES:=brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
-endef
-define Profile/RaspberryPi_3/Description
- Raspberry Pi 3 Model B
-endef
-$(eval $(call Profile,RaspberryPi_3))