aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/bcm53xx/files-4.1/drivers
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/bcm53xx/files-4.1/drivers')
-rw-r--r--target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Kconfig11
-rw-r--r--target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Makefile1
2 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Kconfig b/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Kconfig
index 6bed119930..3c7e5b741e 100644
--- a/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Kconfig
+++ b/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Kconfig
@@ -9,3 +9,14 @@ config BCM47XX_NVRAM
This driver provides an easy way to get value of requested parameter.
It simply reads content of NVRAM and parses it. It doesn't control any
hardware part itself.
+
+config BCM47XX_SPROM
+ bool "Broadcom SPROM driver"
+ depends on BCM47XX_NVRAM
+ help
+ Broadcom devices store configuration data in SPROM. Accessing it is
+ specific to the bus host type, e.g. PCI(e) devices have it mapped in
+ a PCI BAR.
+ In case of SoC devices SPROM content is stored on a flash used by
+ bootloader firmware CFE. This driver provides method to ssb and bcma
+ drivers to read SPROM on SoC.
diff --git a/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Makefile b/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Makefile
index d0e683583c..f93efc479b 100644
--- a/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Makefile
+++ b/target/linux/bcm53xx/files-4.1/drivers/firmware/broadcom/Makefile
@@ -1 +1,2 @@
obj-$(CONFIG_BCM47XX_NVRAM) += bcm47xx_nvram.o
+obj-$(CONFIG_BCM47XX_SPROM) += bcm47xx_sprom.o