aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/patches-3.10/101-early-printk-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/patches-3.10/101-early-printk-support.patch')
-rw-r--r--target/linux/atheros/patches-3.10/101-early-printk-support.patch8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/atheros/patches-3.10/101-early-printk-support.patch b/target/linux/atheros/patches-3.10/101-early-printk-support.patch
index 2346e24918..3daa0117f7 100644
--- a/target/linux/atheros/patches-3.10/101-early-printk-support.patch
+++ b/target/linux/atheros/patches-3.10/101-early-printk-support.patch
@@ -1,6 +1,6 @@
--- /dev/null
+++ b/arch/mips/ar231x/early_printk.c
-@@ -0,0 +1,44 @@
+@@ -0,0 +1,46 @@
+/*
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License. See the file "COPYING" in the main directory of this archive
@@ -40,9 +40,11 @@
+ base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
+ }
+
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++ ;
+ prom_uart_wr(base, UART_TX, ch);
-+ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++ while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++ ;
+}
+
--- a/arch/mips/ar231x/Makefile