aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros-2.6/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros-2.6/image/Makefile')
-rw-r--r--target/linux/atheros-2.6/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/atheros-2.6/image/Makefile b/target/linux/atheros-2.6/image/Makefile
index fb8cf3ced2..80e3335920 100644
--- a/target/linux/atheros-2.6/image/Makefile
+++ b/target/linux/atheros-2.6/image/Makefile
@@ -7,8 +7,12 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Image/Prepare
+ cp $(KDIR)/linux-*/vmlinux $(KDIR)/vmlinux.elf
+endef
+
define Image/BuildKernel
- cp $(KDIR)/linux-*/vmlinux $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.lzma bs=65536 conv=sync