aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-2.6.22/002-led-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/patches-2.6.22/002-led-driver.patch')
-rw-r--r--target/linux/at91/patches-2.6.22/002-led-driver.patch123
1 files changed, 0 insertions, 123 deletions
diff --git a/target/linux/at91/patches-2.6.22/002-led-driver.patch b/target/linux/at91/patches-2.6.22/002-led-driver.patch
deleted file mode 100644
index 481c0f0b6b..0000000000
--- a/target/linux/at91/patches-2.6.22/002-led-driver.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-Index: linux-2.6.22.19/arch/arm/mach-at91/Makefile
-===================================================================
---- linux-2.6.22.19.orig/arch/arm/mach-at91/Makefile
-+++ linux-2.6.22.19/arch/arm/mach-at91/Makefile
-@@ -53,7 +53,7 @@ led-$(CONFIG_MACH_CSB337) += leds.o
- led-$(CONFIG_MACH_CSB637) += leds.o
- led-$(CONFIG_MACH_KB9200) += leds.o
- led-$(CONFIG_MACH_KAFA) += leds.o
--led-$(CONFIG_MACH_VLINK) += leds.o
-+led-$(CONFIG_MACH_VLINK) += vlink_leds.o
- obj-$(CONFIG_LEDS) += $(led-y)
-
- # VGA support
-Index: linux-2.6.22.19/arch/arm/mach-at91/vlink_leds.c
-===================================================================
---- /dev/null
-+++ linux-2.6.22.19/arch/arm/mach-at91/vlink_leds.c
-@@ -0,0 +1,105 @@
-+/*
-+ * LED driver for Atmel AT91-based boards.
-+ *
-+ * Copyright (C) SAN People (Pty) Ltd
-+ * Modified for FDL VersaLink Copyright (C) Guthrie Consulting
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version
-+ * 2 of the License, or (at your option) any later version.
-+*/
-+
-+#include <linux/kernel.h>
-+#include <linux/module.h>
-+#include <linux/init.h>
-+
-+#include <asm/mach-types.h>
-+#include <asm/leds.h>
-+#include <asm/arch/board.h>
-+#include <asm/arch/gpio.h>
-+
-+
-+static inline void at91_led_on(unsigned int led)
-+{
-+ at91_set_gpio_value(led, 0);
-+}
-+
-+static inline void at91_led_off(unsigned int led)
-+{
-+ at91_set_gpio_value(led, 1);
-+}
-+
-+static inline void at91_led_toggle(unsigned int led)
-+{
-+ unsigned long is_off = at91_get_gpio_value(led);
-+ if (is_off) {
-+ at91_led_on(led);
-+ at91_led_off(at91_leds_cpu);
-+ }
-+ else {
-+ at91_led_on(at91_leds_cpu);
-+ at91_led_off(led);
-+ }
-+}
-+
-+
-+/*
-+ * Handle LED events.
-+ */
-+
-+/*
-+ * VersaLink has a single bi-coloured LED which changes colour when the
-+ * polarity is reversed
-+ */
-+static void at91_leds_event(led_event_t evt)
-+{
-+ unsigned long flags;
-+
-+ local_irq_save(flags);
-+
-+ switch(evt) {
-+ case led_start: /* System startup */
-+ at91_led_toggle(at91_leds_timer);
-+ break;
-+
-+ case led_stop: /* System stop / suspend */
-+ at91_led_toggle(at91_leds_timer);
-+ break;
-+
-+#ifdef CONFIG_LEDS_TIMER
-+ case led_timer: /* Every 50 timer ticks */
-+ at91_led_toggle(at91_leds_timer);
-+ break;
-+#endif
-+
-+#ifdef CONFIG_LEDS_CPU
-+ case led_idle_start: /* Entering idle state */
-+ at91_led_toggle(at91_leds_timer);
-+ break;
-+
-+ case led_idle_end: /* Exit idle state */
-+ at91_led_toggle(at91_leds_timer);
-+ break;
-+#endif
-+
-+ default:
-+ break;
-+ }
-+
-+ local_irq_restore(flags);
-+}
-+
-+
-+static int __init leds_init(void)
-+{
-+ if (!at91_leds_timer || !at91_leds_cpu)
-+ return -ENODEV;
-+
-+ leds_event = at91_leds_event;
-+
-+ leds_event(led_start);
-+ return 0;
-+}
-+
-+__initcall(leds_init);