aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch')
-rw-r--r--target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch b/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch
deleted file mode 100644
index ee6a0615d3..0000000000
--- a/target/linux/ar71xx/patches-4.1/815-MIPS-ath79-add-mr1750-support.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -919,6 +919,16 @@ config ATH79_MACH_CAP4200AG
- select ATH79_DEV_M25P80
- select ATH79_DEV_WMAC
-
-+config ATH79_MACH_MR1750
-+ bool "OpenMesh MR1750 board support"
-+ select SOC_QCA955X
-+ select ATH79_DEV_AP9X_PCI if PCI
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_WMAC
-+
- config ATH79_MACH_MR900
- bool "OpenMesh MR900 board support"
- select SOC_QCA955X
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -93,6 +93,7 @@ obj-$(CONFIG_ATH79_MACH_HORNET_UB) += ma
- obj-$(CONFIG_ATH79_MACH_MC_MAC1200R) += mach-mc-mac1200r.o
- obj-$(CONFIG_ATH79_MACH_MR12) += mach-mr12.o
- obj-$(CONFIG_ATH79_MACH_MR16) += mach-mr16.o
-+obj-$(CONFIG_ATH79_MACH_MR1750) += mach-mr1750.o
- obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
- obj-$(CONFIG_ATH79_MACH_MR900) += mach-mr900.o
- obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -82,6 +82,7 @@ enum ath79_mach_type {
- ATH79_MACH_HORNET_UB, /* ALFA Networks Hornet-UB */
- ATH79_MACH_MR12, /* Cisco Meraki MR12 */
- ATH79_MACH_MR16, /* Cisco Meraki MR16 */
-+ ATH79_MACH_MR1750, /* OpenMesh MR1750 */
- ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
- ATH79_MACH_MR600, /* OpenMesh MR600 */
- ATH79_MACH_MR900, /* OpenMesh MR900 */