aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39/500-ar933x-uart-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39/500-ar933x-uart-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/500-ar933x-uart-driver.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/500-ar933x-uart-driver.patch b/target/linux/ar71xx/patches-2.6.39/500-ar933x-uart-driver.patch
deleted file mode 100644
index 530d0576f9..0000000000
--- a/target/linux/ar71xx/patches-2.6.39/500-ar933x-uart-driver.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/drivers/tty/serial/Kconfig
-+++ b/drivers/tty/serial/Kconfig
-@@ -1612,4 +1612,27 @@ config SERIAL_MXS_AUART_CONSOLE
- help
- Enable a MXS AUART port to be the system console.
-
-+config SERIAL_AR933X
-+ bool "AR933X serial port support"
-+ depends on SOC_AR933X
-+ select SERIAL_CORE
-+ help
-+ If you have an Atheros AR933X SOC based board and want to use the
-+ built-in UART of the SoC, say Y to this option.
-+
-+config SERIAL_AR933X_CONSOLE
-+ bool "Console on AR933X serial port"
-+ depends on SERIAL_AR933X=y
-+ select SERIAL_CORE_CONSOLE
-+ help
-+ Enable a built-in UART port of the AR933X to be the system console.
-+
-+config SERIAL_AR933X_NR_UARTS
-+ int "Maximum number of AR933X serial ports"
-+ depends on SERIAL_AR933X
-+ default "2"
-+ help
-+ Set this to the number of serial ports you want the driver
-+ to support.
-+
- endmenu
---- a/drivers/tty/serial/Makefile
-+++ b/drivers/tty/serial/Makefile
-@@ -94,3 +94,4 @@ obj-$(CONFIG_SERIAL_IFX6X60) += ifx6x6
- obj-$(CONFIG_SERIAL_PCH_UART) += pch_uart.o
- obj-$(CONFIG_SERIAL_MSM_SMD) += msm_smd_tty.o
- obj-$(CONFIG_SERIAL_MXS_AUART) += mxs-auart.o
-+obj-$(CONFIG_SERIAL_AR933X) += ar933x_uart.o
---- a/include/linux/serial_core.h
-+++ b/include/linux/serial_core.h
-@@ -202,6 +202,10 @@
- /* VIA VT8500 SoC */
- #define PORT_VT8500 97
-
-+/* Atheros AR933X SoC */
-+#define PORT_AR933X 99
-+
-+
- #ifdef __KERNEL__
-
- #include <linux/compiler.h>