aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/modules.mk')
-rw-r--r--target/linux/ar71xx/modules.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/target/linux/ar71xx/modules.mk b/target/linux/ar71xx/modules.mk
new file mode 100644
index 0000000000..18f0c4ae50
--- /dev/null
+++ b/target/linux/ar71xx/modules.mk
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/leds-rb750
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=RouterBOARD 750 LED support
+ DEPENDS:=@TARGET_ar71xx
+ KCONFIG:=CONFIG_LEDS_RB750
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-rb750.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-rb750)
+endef
+
+define KernelPackage/leds-rb750/description
+ Kernel module for the LEDs on the MikroTik RouterBOARD 750.
+endef
+
+$(eval $(call KernelPackage,leds-rb750))
+
+
+define KernelPackage/leds-wndr3700-usb
+ SUBMENU:=$(LEDS_MENU)
+ TITLE:=WNDR3700 USB LED support
+ DEPENDS:=@TARGET_ar71xx
+ KCONFIG:=CONFIG_LEDS_WNDR3700_USB
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-wndr3700-usb.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-wndr3700-usb)
+endef
+
+define KernelPackage/leds-wndr3700-usb/description
+ Kernel module for the USB LED on the NETGWR WNDR3700 board.
+endef
+
+$(eval $(call KernelPackage,leds-wndr3700-usb))