aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/patches/100-board.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/amazon/patches/100-board.patch')
-rw-r--r--target/linux/amazon/patches/100-board.patch59
1 files changed, 0 insertions, 59 deletions
diff --git a/target/linux/amazon/patches/100-board.patch b/target/linux/amazon/patches/100-board.patch
deleted file mode 100644
index 6c03e70b6e..0000000000
--- a/target/linux/amazon/patches/100-board.patch
+++ /dev/null
@@ -1,59 +0,0 @@
---- a/arch/mips/Kconfig
-+++ b/arch/mips/Kconfig
-@@ -159,6 +159,17 @@ config BASLER_EXCITE_PROTOTYPE
- note that a kernel built with this option selected will not be
- able to run on normal units.
-
-+config AMAZON
-+ bool "Amazon support (EXPERIMENTAL)"
-+ depends on EXPERIMENTAL
-+ select DMA_NONCOHERENT
-+ select IRQ_CPU
-+ select SYS_HAS_CPU_MIPS32_R1
-+ select HAVE_STD_PC_SERIAL_PORT
-+ select SYS_SUPPORTS_BIG_ENDIAN
-+ select SYS_SUPPORTS_32BIT_KERNEL
-+ select SYS_HAS_EARLY_PRINTK
-+
- config MIPS_COBALT
- bool "Cobalt Server"
- select DMA_NONCOHERENT
-@@ -823,6 +834,7 @@ config TOSHIBA_RBTX4938
-
- endchoice
-
-+source "arch/mips/amazon/Kconfig"
- source "arch/mips/ddb5xxx/Kconfig"
- source "arch/mips/gt64120/ev64120/Kconfig"
- source "arch/mips/jazz/Kconfig"
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -267,6 +267,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
- load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
-
- #
-+# Infineon AMAZON
-+#
-+core-$(CONFIG_AMAZON) += arch/mips/amazon/
-+cflags-$(CONFIG_AMAZON) += -Iinclude/asm-mips/mach-amazon
-+load-$(CONFIG_AMAZON) += 0xffffffff80002000
-+
-+#
- # Cobalt Server
- #
- core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/
---- a/include/asm-mips/bootinfo.h
-+++ b/include/asm-mips/bootinfo.h
-@@ -213,6 +213,12 @@
- #define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
- #define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
-
-+/*
-+ * Valid machtype for group Infineon
-+ */
-+#define MACH_GROUP_INFINEON 27
-+#define MACH_INFINEON_AMAZON 0
-+
- #define CL_SIZE COMMAND_LINE_SIZE
-
- const char *get_system_type(void);