aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/router_be/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/router_be/profiles')
-rw-r--r--target/linux/adm5120/router_be/profiles/090-Zyxel.mk17
-rw-r--r--target/linux/adm5120/router_be/profiles/100-Texas.mk17
-rw-r--r--target/linux/adm5120/router_be/profiles/110-Atheros.mk17
-rw-r--r--target/linux/adm5120/router_be/profiles/110-None.mk17
4 files changed, 68 insertions, 0 deletions
diff --git a/target/linux/adm5120/router_be/profiles/090-Zyxel.mk b/target/linux/adm5120/router_be/profiles/090-Zyxel.mk
new file mode 100644
index 0000000000..b0741e84be
--- /dev/null
+++ b/target/linux/adm5120/router_be/profiles/090-Zyxel.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Zyxel
+ NAME:=Zyxel Prestige P-334/335/335-WT (default)
+ PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/Zyxel/Description
+ Package set compatible with the Zyxel prestige P-334/335/335-WT boards
+endef
+$(eval $(call Profile,Zyxel))
+
diff --git a/target/linux/adm5120/router_be/profiles/100-Texas.mk b/target/linux/adm5120/router_be/profiles/100-Texas.mk
new file mode 100644
index 0000000000..727a0c0648
--- /dev/null
+++ b/target/linux/adm5120/router_be/profiles/100-Texas.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Texas
+ NAME:=Texas Instruments WiFi
+ PACKAGES:=kmod-acx
+endef
+
+define Profile/Texas/Description
+ Package set compatible with hardware using Texas Instruments WiFi cards
+endef
+$(eval $(call Profile,Texas))
+
diff --git a/target/linux/adm5120/router_be/profiles/110-Atheros.mk b/target/linux/adm5120/router_be/profiles/110-Atheros.mk
new file mode 100644
index 0000000000..cc4a704495
--- /dev/null
+++ b/target/linux/adm5120/router_be/profiles/110-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/adm5120/router_be/profiles/110-None.mk b/target/linux/adm5120/router_be/profiles/110-None.mk
new file mode 100644
index 0000000000..2fcfacde9f
--- /dev/null
+++ b/target/linux/adm5120/router_be/profiles/110-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+